CH340 USB Serial Chip Treiber für Mac OS

ch340_arduino_nanoDen Mac OS Treiber für den CH340 USB-Serial Chip gibt es nun auch signiert, so das man ihn ohne die Sicherheitsmechanismen von Mac OS 10.9 / 10.10 oder 10.11 aushebeln zu müssen, installieren kann.
Vor einiger Zeit hat es FTDI, ein Hersteller eines sehr verbreiteten Chips zum Umsetzen von Seriellen Verbindungen auf USB geschafft die Elektronikgemeinde zu verärgern, indem er Treiber veröffentlichte, welche Nachbauten der ICs unbrauchbar machten. Damit traf der Hersteller aber nicht die Firmen welche die Chips klonen, sondern Verbraucher deren Geräte plötzlich unbrauchbar wurden.
Nun scheint es so zu sein, das ein erneutes Update der Treiber dafür sorgt das statt der übertragenen Daten der Text „NON GENUINE DEVICE FOUND!“ ausgibt. Siehe den Bericht auf Hackaday. Diverse Hersteller von Produkten, sind daher zu einem anderen Hersteller gewechselt. Gerade die preiswerten Arduino Klone sind nun häufig mit dem CH340 ausgestattet. Einem Chip der zwar das gleiche macht wie der originale FTDI Chip, der aber einen anderen Treiber benötigt, der bisher nur mit einigen Verrenkungen auf einem neueren Mac OS installierbar war.
Offensichtlich gibt es den Treiber aber mittlerweile in signierter Form, so dass er ohne das Umgehen der „System Integrity Protextion“ von z.B. El Capitan installiert werden kann.
Der Treiber findet sich auf der Downloadseite des Herstellers: http://wch.cn/download/CH341SER_MAC_ZIP.html
Nach dem Auspacken des ZIP-Files findet sich ein PKG-File das einfach Installiert werden kann. Ich habe das gerade auf einem Macbook Air 2015 mit El Capitan Version 10.11.4 (15E65) erfolgreich getestet. Nach der Installation ist ein Reboot notwendig, danach erkennt die Arduino IDE den Chip unter seiner ID als z.B. /dev/cu.wchusbserial1420.
Ich habe bei Tests (Arduino nano Klon) die Erfahrung gemacht, das ein Upload nicht immer auf Anhieb funktioniert. Hier hat es geholfen die IDE einmal zu beenden, den Arduino vom USB Port abzuziehen, wieder anzustecken und dann die IDE zu starten. Danach war ein Upload ohne Probleme durchführbar.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

*